Different PHP & JS packages used in the script need a server which fulfills following requirements:

  • PHP >= 7.1.3
  • OpenSSL PHP Extension
  • PDO PHP Extension
  • Mbstring PHP Extension
  • Tokenizer PHP Extension
  • XML PHP Extension
  • Fileinfo Extension
  • Mcrypt Extension
  • Zip Archive Extension
  • Curl Support + allow_url_fopen enabled
  • Mysql Native Driver Support
  • GD Image Library

Beside this, below are the folders & files should be writable by the script:

  • Storage/framework
  • Storage/logs
  • Bootstrap/cache
  • .env (Environmental File)


The script also requires to support wildcard subdomain so that it can create dynamic subdomains for your client account and the script should have enough permission so that it can create database itself to accomplish multi-tenant feature.


The script is tested with following server which fulfills above requirement:

  • WAMP 3.1.0 64 Bit Local Server (You can use this for further development & customization in the script)
  • cPanel
  • Plesk Panel

Your server doesn’t require much system resources, you can host this script in shared server or you can choose to proceed with VPS or Dedicated server. As number of client increases, you can increase system resources. You can also choose cloud hosting such as google cloud, amazon cloud etc.


If you are looking for further customize the script, you need to install node.js in your server.


Note: Laravel framework pre-requisites are changed with release of every new version. Pre-requisites of this script 100% depends upon the pre-requisites of Laravel framework and its package used to code the script. Update may require server to fulfill updated requirement of the script.